TWINT Service Disruption RICOH MFP Kiosk

Incident Report for KUARIO

Resolved

The issue with our payment provider has been resolved. Twint payments can once again be made on Ricoh MFPs.
Posted Feb 25, 2026 - 07:20 CET

Investigating

We are currently experiencing a Service Disruption regarding TWINT payments with RICOH MFP Kiosk.
We are investigating the issue.
Posted Feb 24, 2026 - 17:03 CET
This incident affected: KUARIO Platform (Main API, Payment API, Print API, Monitoring API, Scan API, Import API) and Services (Business Portal, Personal portal, KUARIO Website, KUARIO Apps).