Problem paying at PayBox

Incident Report for KUARIO

Resolved

Fix for the problem has been implemented. Payments using the PayBox no longer cause problems.
Posted Jun 05, 2025 - 16:20 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 05, 2025 - 16:18 CEST

Investigating

We are currently experiencing problems with customers trying to pay via the Nayax Pinterminal
Posted Jun 05, 2025 - 15:55 CEST