We are currently experiencing lower performance of the KUARIO platform.

Incident Report for KUARIO

Resolved

Process found that causes performance issues. Issue resolved.
Posted Sep 02, 2025 - 11:14 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2025 - 11:00 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2025 - 10:50 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2025 - 10:38 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2025 - 10:35 CEST

Investigating

We are currently investigating this issue.
Posted Sep 02, 2025 - 10:25 CEST
This incident affected: KUARIO Platform (Main API, Payment API, Import API) and Services (Business Portal, Personal portal, KUARIO Apps).