Issue with VISA (Euro) top-ups and payment

Incident Report for KUARIO

Resolved

Visa has tightened its rules for accepting cards outside the EEA. As a result, many payments are being refused by users with Visa cards outside the EEA. Unfortunately, these users can only top-up via another method.
Posted Feb 13, 2025 - 20:57 CET

Identified

Visa transactions outside the EU are currently denied.
Posted Feb 13, 2025 - 15:15 CET

Investigating

A large number of our customers are currently experiencing problems making VISA Euro payments and top-ups. Our PSP is investigating the cause of this problem.
Posted Feb 13, 2025 - 10:30 CET
This incident affected: KUARIO Platform (Payment API).